re = /([#\.][a-z0-9]*?\.?.*?)\s?\{([^\{\}]*)\}/mi
str = '#header { background: red; font-size: 14px; color:white; }
#header { background: red; font-size: 14px; color:white; }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end