package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([#\.][a-z0-9]*?\.?.*?)\s?\{([^\{\}]*)\}`)
var str = `#header { background: red; font-size: 14px; color:white; }
#header { background: red; font-size: 14px; color:white; }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}