#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"Integer""
Local $sString = "Integer a = 3; " & @CRLF & _
"" & @CRLF & _
"if(a > 5){" & @CRLF & _
" float b = 3.5;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"while (a++){" & @CRLF & _
" a = a + 1;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")