import re
regex = re.compile(r"\"Integer\"", flags=re.MULTILINE)
test_str = ("Integer a = 3; \n\n"
"if(a > 5){\n"
" float b = 3.5;\n"
"}\n\n"
"while (a++){\n"
" a = a + 1;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")