package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"Integer"`)
var str = `Integer a = 3;
if(a > 5){
float b = 3.5;
}
while (a++){
a = a + 1;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}