$re = '/"Integer"/m';
$str = 'Integer a = 3;
if(a > 5){
float b = 3.5;
}
while (a++){
a = a + 1;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);