re = /"Integer"/m
str = 'Integer a = 3;
if(a > 5){
float b = 3.5;
}
while (a++){
a = a + 1;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end