using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"abc.aspx\?.*[?;]?yid=(\d+)";
string input = @"abc.aspx?sdfsdfds;eter;yid=10
abc.aspx?yid=10;sdfsdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}