re = /abc.aspx\?.*[?;]?yid=(\d+)/
str = 'abc.aspx?sdfsdfds;eter;yid=10
abc.aspx?yid=10;sdfsdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end