$re = '/abc.aspx\?.*[?;]?yid=(\d+)/';
$str = 'abc.aspx?sdfsdfds;eter;yid=10
abc.aspx?yid=10;sdfsdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);