const regex = /abc.aspx\?.*[?;]?yid=(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('abc.aspx\\?.*[?;]?yid=(\\d+)', 'g')
const str = `abc.aspx?sdfsdfds;eter;yid=10
abc.aspx?yid=10;sdfsdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}