package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`abc.aspx\?.*[?;]?yid=(\d+)`)
var str = `abc.aspx?sdfsdfds;eter;yid=10
abc.aspx?yid=10;sdfsdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}