// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"abc.aspx\?.*[?;]?yid=(\d+)").unwrap();
let string = "abc.aspx?sdfsdfds;eter;yid=10
abc.aspx?yid=10;sdfsdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}