#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<master>([a-zA-Z0-9_]*\.|))Sequence\((\s*|)((!?(?P=master))([a-zA-Z0-9_]*)\(([a-zA-Z0-9_\(\)\,=>\{\}\s]*)\)(\,\s*|\,\n|\,|()))*(\n|)\)\;" & @CRLF & _
""
Local $sString = "this.Sequence(this.Delay(1));" & @CRLF & _
"" & @CRLF & _
"this.Sequence(this.Delay(1),this.Delay(1));" & @CRLF & _
"" & @CRLF & _
"other.Sequence(this.Delay(1)); other.Sequence(this.Delay(1));" & @CRLF & _
"other.Sequence(other.Delay(1));" & @CRLF & _
"this.Sequence(other.Delay(1));" & @CRLF & _
"" & @CRLF & _
"Sequence(" & @CRLF & _
" this.Delay(1)" & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"Sequence(" & @CRLF & _
" this.Delay(1)," & @CRLF & _
" this.Delay(1)," & @CRLF & _
" this.Value(1, 0, 1, (v)=>{})," & @CRLF & _
" this.Value(1,0,1, delegate(v){})," & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//coment" & @CRLF & _
"a = 1;" & @CRLF & _
"this.GetPosition();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")