use strict;
my $str = 'this.Sequence(this.Delay(1));
this.Sequence(this.Delay(1),this.Delay(1));
other.Sequence(this.Delay(1)); other.Sequence(this.Delay(1));
other.Sequence(other.Delay(1));
this.Sequence(other.Delay(1));
Sequence(
this.Delay(1)
);
Sequence(
this.Delay(1),
this.Delay(1),
this.Value(1, 0, 1, (v)=>{}),
this.Value(1,0,1, delegate(v){}),
);
//coment
a = 1;
this.GetPosition();';
my $regex = qr/(?P<master>([a-zA-Z0-9_]*\.|))Sequence\((\s*|)((!?(?P=master))([a-zA-Z0-9_]*)\(([a-zA-Z0-9_\(\)\,=>\{\}\s]*)\)(\,\s*|\,\n|\,|()))*(\n|)\)\;
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}