// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<master>([a-zA-Z0-9_]*\.|))Sequence\((\s*|)((!?(?P=master))([a-zA-Z0-9_]*)\(([a-zA-Z0-9_\(\)\,=>\{\}\s]*)\)(\,\s*|\,\n|\,|()))*(\n|)\)\;
").unwrap();
let string = "this.Sequence(this.Delay(1));
this.Sequence(this.Delay(1),this.Delay(1));
other.Sequence(this.Delay(1)); other.Sequence(this.Delay(1));
other.Sequence(other.Delay(1));
this.Sequence(other.Delay(1));
Sequence(
this.Delay(1)
);
Sequence(
this.Delay(1),
this.Delay(1),
this.Value(1, 0, 1, (v)=>{}),
this.Value(1,0,1, delegate(v){}),
);
//coment
a = 1;
this.GetPosition();";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}