using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<master>([a-zA-Z0-9_]*\.|))Sequence\((\s*|)((!?(?P=master))([a-zA-Z0-9_]*)\(([a-zA-Z0-9_\(\)\,=>\{\}\s]*)\)(\,\s*|\,\n|\,|()))*(\n|)\)\;
";
string input = @"this.Sequence(this.Delay(1));
this.Sequence(this.Delay(1),this.Delay(1));
other.Sequence(this.Delay(1)); other.Sequence(this.Delay(1));
other.Sequence(other.Delay(1));
this.Sequence(other.Delay(1));
Sequence(
this.Delay(1)
);
Sequence(
this.Delay(1),
this.Delay(1),
this.Value(1, 0, 1, (v)=>{}),
this.Value(1,0,1, delegate(v){}),
);
//coment
a = 1;
this.GetPosition();";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}