import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<master>([a-zA-Z0-9_]*\\.|))Sequence\\((\\s*|)((!?(?P=master))([a-zA-Z0-9_]*)\\(([a-zA-Z0-9_\\(\\)\\,=>\\{\\}\\s]*)\\)(\\,\\s*|\\,\\n|\\,|()))*(\\n|)\\)\\;\n";
final String string = "this.Sequence(this.Delay(1));\n\n"
+ "this.Sequence(this.Delay(1),this.Delay(1));\n\n"
+ "other.Sequence(this.Delay(1)); other.Sequence(this.Delay(1));\n"
+ "other.Sequence(other.Delay(1));\n"
+ "this.Sequence(other.Delay(1));\n\n"
+ "Sequence(\n"
+ " this.Delay(1)\n"
+ ");\n\n"
+ "Sequence(\n"
+ " this.Delay(1),\n"
+ " this.Delay(1),\n"
+ " this.Value(1, 0, 1, (v)=>{}),\n"
+ " this.Value(1,0,1, delegate(v){}),\n"
+ ");\n\n\n"
+ "//coment\n"
+ "a = 1;\n"
+ "this.GetPosition();";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}