# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9]+)[a-zA-Z]{2}/$1/gm;t' <<< "my random text goes here with th in it..... \"11th March\" ....my random text goes here with th in it. my random text goes here with nd in it..... \"02nd March\" ....my random text goes here with nd in it. my random text goes here with st in it..... \"01st March\" ....my random text goes here with st in it."