using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]+)[a-zA-Z]{2}";
string substitution = @"$1";
string input = @"my random text goes here with th in it..... ""11th March"" ....my random text goes here with th in it. my random text goes here with nd in it..... ""02nd March"" ....my random text goes here with nd in it. my random text goes here with st in it..... ""01st March"" ....my random text goes here with st in it.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}