# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]+)[a-zA-Z]{2}"
test_str = "my random text goes here with th in it..... \"11th March\" ....my random text goes here with th in it. my random text goes here with nd in it..... \"02nd March\" ....my random text goes here with nd in it. my random text goes here with st in it..... \"01st March\" ....my random text goes here with st in it."
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.