use strict;
my $str = 'my random text goes here with th in it..... "11th March" ....my random text goes here with th in it. my random text goes here with nd in it..... "02nd March" ....my random text goes here with nd in it. my random text goes here with st in it..... "01st March" ....my random text goes here with st in it.';
my $regex = qr~([0-9]+)[a-zA-Z]{2}~mp;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";