const regex = new RegExp('([0-9]+)[a-zA-Z]{2}', 'gm')
const str = `my random text goes here with th in it..... "11th March" ....my random text goes here with th in it. my random text goes here with nd in it..... "02nd March" ....my random text goes here with nd in it. my random text goes here with st in it..... "01st March" ....my random text goes here with st in it.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);