import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+)[a-zA-Z]{2}";
final String string = "my random text goes here with th in it..... \"11th March\" ....my random text goes here with th in it. my random text goes here with nd in it..... \"02nd March\" ....my random text goes here with nd in it. my random text goes here with st in it..... \"01st March\" ....my random text goes here with st in it.";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}