using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"uk\.co\.autotrader:autotrader-spring-boot-?.*:\""?\${?\K[a-zA-Z-]*";
string input = @"uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}
uk.co.autotrader:autotrader-spring-boot-dependencies:""$autotraderSpringbootVersion""
uk.co.autotrader:autotrader-spring-boot-dependencies:$autotraderSpringbootVersion
uk.co.autotrader:autotrader-spring-boot-dependencies:$someothername
uk.co.autotrader:autotrader-spring-boot-dependencies:2.3.0.1
uk.co.autotrader:autotrader-spring-boot:${autotraderSpringbootVersion}
uk.co.autotrader:autotrader-spring-boot:""$autotraderSpringbootVersion""
uk.co.autotrader:autotrader-spring-boot:$autotraderSpringbootVersion
""uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}""
uk.co.autotrader:autotrader-spring-boot:2.3.0.1
(regex to find match upto dollar working)
uk.co.autotrader:autotrader-spring-boot.*:\""?\$
$
""$
""${
${
\$\""?\{?
(regex to find match of text following dollar sign)
uk.co.autotrader:autotrader-spring-boot(\$\""?\{?)[a-zA-Z]*
uk\.co\.autotrader:autotrader-spring-boot:(?=[\$\""?\{?])[a-zA-Z-]*";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}