re = /uk\.co\.autotrader:autotrader-spring-boot-?.*:\"?\${?\K[a-zA-Z-]*/m
str = 'uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}
uk.co.autotrader:autotrader-spring-boot-dependencies:"$autotraderSpringbootVersion"
uk.co.autotrader:autotrader-spring-boot-dependencies:$autotraderSpringbootVersion
uk.co.autotrader:autotrader-spring-boot-dependencies:$someothername
uk.co.autotrader:autotrader-spring-boot-dependencies:2.3.0.1
uk.co.autotrader:autotrader-spring-boot:${autotraderSpringbootVersion}
uk.co.autotrader:autotrader-spring-boot:"$autotraderSpringbootVersion"
uk.co.autotrader:autotrader-spring-boot:$autotraderSpringbootVersion
"uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}"
uk.co.autotrader:autotrader-spring-boot:2.3.0.1
(regex to find match upto dollar working)
uk.co.autotrader:autotrader-spring-boot.*:\\"?\\$
$
"$
"${
${
\\$\\"?\\{?
(regex to find match of text following dollar sign)
uk.co.autotrader:autotrader-spring-boot(\\$\\"?\\{?)[a-zA-Z]*
uk\\.co\\.autotrader:autotrader-spring-boot:(?=[\\$\\"?\\{?])[a-zA-Z-]*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end