import re
regex = re.compile(r"uk\.co\.autotrader:autotrader-spring-boot-?.*:\"?\${?\K[a-zA-Z-]*", flags=re.MULTILINE)
test_str = ("uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}\n"
"uk.co.autotrader:autotrader-spring-boot-dependencies:\"$autotraderSpringbootVersion\"\n"
"uk.co.autotrader:autotrader-spring-boot-dependencies:$autotraderSpringbootVersion\n"
"uk.co.autotrader:autotrader-spring-boot-dependencies:$someothername\n\n"
"uk.co.autotrader:autotrader-spring-boot-dependencies:2.3.0.1\n\n\n"
"uk.co.autotrader:autotrader-spring-boot:${autotraderSpringbootVersion}\n"
"uk.co.autotrader:autotrader-spring-boot:\"$autotraderSpringbootVersion\"\n"
"uk.co.autotrader:autotrader-spring-boot:$autotraderSpringbootVersion\n\n"
" \"uk.co.autotrader:autotrader-spring-boot-dependencies:${autotraderSpringbootVersion}\"\n\n"
"uk.co.autotrader:autotrader-spring-boot:2.3.0.1\n\n\n"
"(regex to find match upto dollar working)\n"
"uk.co.autotrader:autotrader-spring-boot.*:\\\"?\\$\n\n\n"
"$\n"
"\"$\n"
"\"${\n"
"${\n\n\n"
"\\$\\\"?\\{?\n\n\n"
"(regex to find match of text following dollar sign)\n"
"uk.co.autotrader:autotrader-spring-boot(\\$\\\"?\\{?)[a-zA-Z]*\n\n\n"
"uk\\.co\\.autotrader:autotrader-spring-boot:(?=[\\$\\\"?\\{?])[a-zA-Z-]*")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")