# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\w+)[\s\(](?:at|@)[\s\)](\w+)(?:\sdot\s(\w+)\sdot\s|\.(\w+)\.)edu$//gm;t' <<< "csk at cs dot xyz dot edu
csk(at)cs dot xyz dot edu
csk at cs.xyz.edu
csk(at)cs.xyz.edu
csk at cs.xyz.edu
csk(@)cs.xyz.edu
csk @ cs dot xyz dot edu"