package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+)[\s\(](?:at|@)[\s\)](\w+)(?:\sdot\s(\w+)\sdot\s|\.(\w+)\.)edu$`)
var str = `csk at cs dot xyz dot edu
csk(at)cs dot xyz dot edu
csk at cs.xyz.edu
csk(at)cs.xyz.edu
csk at cs.xyz.edu
csk(@)cs.xyz.edu
csk @ cs dot xyz dot edu`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}