using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+)[\s\(](?:at|@)[\s\)](\w+)(?:\sdot\s(\w+)\sdot\s|\.(\w+)\.)edu$";
string substitution = @"";
string input = @"csk at cs dot xyz dot edu
csk(at)cs dot xyz dot edu
csk at cs.xyz.edu
csk(at)cs.xyz.edu
csk at cs.xyz.edu
csk(@)cs.xyz.edu
csk @ cs dot xyz dot edu";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}