use strict;
my $str = 'csk at cs dot xyz dot edu
csk(at)cs dot xyz dot edu
csk at cs.xyz.edu
csk(at)cs.xyz.edu
csk at cs.xyz.edu
csk(@)cs.xyz.edu
csk @ cs dot xyz dot edu';
my $regex = qr/^(\w+)[\s\(](?:at|@)[\s\)](\w+)(?:\sdot\s(\w+)\sdot\s|\.(\w+)\.)edu$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";