import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+)[\\s\\(](?:at|@)[\\s\\)](\\w+)(?:\\sdot\\s(\\w+)\\sdot\\s|\\.(\\w+)\\.)edu$";
final String string = "csk at cs dot xyz dot edu\n"
+ "csk(at)cs dot xyz dot edu\n"
+ "csk at cs.xyz.edu\n"
+ "csk(at)cs.xyz.edu\n"
+ "csk at cs.xyz.edu\n"
+ "csk(@)cs.xyz.edu\n"
+ "csk @ cs dot xyz dot edu";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}