import Foundation
let pattern = #"^(\w+)[\s\(](?:at|@)[\s\)](\w+)(?:\sdot\s(\w+)\sdot\s|\.(\w+)\.)edu$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
csk at cs dot xyz dot edu
csk(at)cs dot xyz dot edu
csk at cs.xyz.edu
csk(at)cs.xyz.edu
csk at cs.xyz.edu
csk(@)cs.xyz.edu
csk @ cs dot xyz dot edu
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)