using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(public|private|protected|internal)?( )+class( )+([a-z_][a-z0-9_]*)( )*((:|,)( )+([a-z_][a-z0-9_]*)( )*)*{";
string input = @"public class NomeDaClass : Pai, Interface{
public class NomeDaClass {
protected class ClasseDaLoca{
internal class ClasseDaLoca : Img{
}((:|,)( )+([a-z_][a-z0-9_]*){1,})?";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}