import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(public|private|protected|internal)?( )+class( )+([a-z_][a-z0-9_]*)( )*((:|,)( )+([a-z_][a-z0-9_]*)( )*)*\\{";
final String string = "public class NomeDaClass : Pai, Interface{\n"
+ "public class NomeDaClass {\n"
+ "protected class ClasseDaLoca{\n"
+ "internal class ClasseDaLoca : Img{\n"
+ " \n\n"
+ "}((:|,)( )+([a-z_][a-z0-9_]*){1,})?";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}