// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(public|private|protected|internal)?( )+class( )+([a-z_][a-z0-9_]*)( )*((:|,)( )+([a-z_][a-z0-9_]*)( )*)*{").unwrap();
let string = "public class NomeDaClass : Pai, Interface{
public class NomeDaClass {
protected class ClasseDaLoca{
internal class ClasseDaLoca : Img{
}((:|,)( )+([a-z_][a-z0-9_]*){1,})?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}