using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?:(?:kind(?:est)* )*regards?|cheers?|greetings?|thanks|thank you)\b,?.*[\r\n]{0,2}.*(?:[.!?: ]*|$)";
string input = @"cheers!
cheers.
regards
timmy
kindest regards,
SomeUser
greetings,
Jimmy
Kindest regards Rasmus
--
Kindest regards,
Garry McAnswerer
--
Thanks,
Matt
Thanks a head of time
Kris
Thank you all,
Joe
Cheers,
WARNING: This regex currently removes ALL text in the next non-blank line following the beginning of a ""complimentaryClose"", up to 2 lines after. This may stil be too greedy.
LEAVE:
Regarding your first question...
This worked OK:
/[\r\n]*(?:(?:kind(?:est)* )*regards|cheers?|greetings?),?[\t\f ]*[\r\n]*\w*(?:[,.!?: ]*|$)/gi";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}