use strict;
my $str = 'cheers!
cheers.
regards
timmy
kindest regards,
SomeUser
greetings,
Jimmy
Kindest regards Rasmus
--
Kindest regards,
Garry McAnswerer
--
Thanks,
Matt
Thanks a head of time
Kris
Thank you all,
Joe
Cheers,
WARNING: This regex currently removes ALL text in the next non-blank line following the beginning of a "complimentaryClose", up to 2 lines after. This may stil be too greedy.
LEAVE:
Regarding your first question...
This worked OK:
/[\\r\\n]*(?:(?:kind(?:est)* )*regards|cheers?|greetings?),?[\\t\\f ]*[\\r\\n]*\\w*(?:[,.!?: ]*|$)/gi';
my $regex = qr/^\s*(?:(?:kind(?:est)* )*regards?|cheers?|greetings?|thanks|thank you)\b,?.*[\r\n]{0,2}.*(?:[.!?: ]*|$)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}