const regex = /^\s*(?:(?:kind(?:est)* )*regards?|cheers?|greetings?|thanks|thank you)\b,?.*[\r\n]{0,2}.*(?:[.!?: ]*|$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?:(?:kind(?:est)* )*regards?|cheers?|greetings?|thanks|thank you)\\b,?.*[\\r\\n]{0,2}.*(?:[.!?: ]*|$)', 'gim')
const str = `cheers!
cheers.
regards
timmy
kindest regards,
SomeUser
greetings,
Jimmy
Kindest regards Rasmus
--
Kindest regards,
Garry McAnswerer
--
Thanks,
Matt
Thanks a head of time
Kris
Thank you all,
Joe
Cheers,
WARNING: This regex currently removes ALL text in the next non-blank line following the beginning of a "complimentaryClose", up to 2 lines after. This may stil be too greedy.
LEAVE:
Regarding your first question...
This worked OK:
/[\\r\\n]*(?:(?:kind(?:est)* )*regards|cheers?|greetings?),?[\\t\\f ]*[\\r\\n]*\\w*(?:[,.!?: ]*|\$)/gi`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}