$re = '/^\s*(?:(?:kind(?:est)* )*regards?|cheers?|greetings?|thanks|thank you)\b,?.*[\r\n]{0,2}.*(?:[.!?: ]*|$)/im';
$str = 'cheers!
cheers.
regards
timmy
kindest regards,
SomeUser
greetings,
Jimmy
Kindest regards Rasmus
--
Kindest regards,
Garry McAnswerer
--
Thanks,
Matt
Thanks a head of time
Kris
Thank you all,
Joe
Cheers,
WARNING: This regex currently removes ALL text in the next non-blank line following the beginning of a "complimentaryClose", up to 2 lines after. This may stil be too greedy.
LEAVE:
Regarding your first question...
This worked OK:
/[\\r\\n]*(?:(?:kind(?:est)* )*regards|cheers?|greetings?),?[\\t\\f ]*[\\r\\n]*\\w*(?:[,.!?: ]*|$)/gi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);