import Foundation
let pattern = #"^\s*(?:(?:kind(?:est)* )*regards?|cheers?|greetings?|thanks|thank you)\b,?.*[\r\n]{0,2}.*(?:[.!?: ]*|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
cheers!
cheers.
regards
timmy
kindest regards,
SomeUser
greetings,
Jimmy
Kindest regards Rasmus
--
Kindest regards,
Garry McAnswerer
--
Thanks,
Matt
Thanks a head of time
Kris
Thank you all,
Joe
Cheers,
WARNING: This regex currently removes ALL text in the next non-blank line following the beginning of a "complimentaryClose", up to 2 lines after. This may stil be too greedy.
LEAVE:
Regarding your first question...
This worked OK:
/[\r\n]*(?:(?:kind(?:est)* )*regards|cheers?|greetings?),?[\t\f ]*[\r\n]*\w*(?:[,.!?: ]*|$)/gi
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)