import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:(?:kind(?:est)* )*regards?|cheers?|greetings?|thanks|thank you)\\b,?.*[\\r\\n]{0,2}.*(?:[.!?: ]*|$)";
final String string = "cheers!\n"
+ "cheers.\n\n"
+ "regards\n\n"
+ "timmy\n\n"
+ "kindest regards,\n"
+ "SomeUser\n\n"
+ "greetings,\n"
+ "Jimmy\n\n"
+ "Kindest regards Rasmus\n"
+ "--\n"
+ "Kindest regards,\n\n"
+ "Garry McAnswerer\n"
+ "--\n\n"
+ "Thanks,\n\n"
+ "Matt\n\n"
+ "Thanks a head of time\n"
+ "Kris\n\n"
+ "Thank you all,\n"
+ "Joe\n\n"
+ "Cheers,\n\n"
+ "WARNING: This regex currently removes ALL text in the next non-blank line following the beginning of a \"complimentaryClose\", up to 2 lines after. This may stil be too greedy.\n\n"
+ "LEAVE:\n\n"
+ "Regarding your first question...\n\n"
+ "This worked OK:\n\n"
+ "/[\\r\\n]*(?:(?:kind(?:est)* )*regards|cheers?|greetings?),?[\\t\\f ]*[\\r\\n]*\\w*(?:[,.!?: ]*|$)/gi";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}