using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\p{Lu})(?!.*(.)\1$)\p{Cyrillic}{3,}$";
string input = @"вася
ва
Ва
Вася
Васяя
It's Cyrillic
It's minimum 3 letters
It doesnt have space
The last letters doesnt repeat, i.e Gabenn <- is wrong, Moneyy <- is wrong, beucase the last 2 letters are repeating
First letter is capital";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}