const regex = /^(?=\p{Lu})(?!.*(.)\1$)\p{Cyrillic}{3,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\p{Lu})(?!.*(.)\\1$)\\p{Cyrillic}{3,}$', 'gm')
const str = `вася
ва
Ва
Вася
Васяя
It's Cyrillic
It's minimum 3 letters
It doesnt have space
The last letters doesnt repeat, i.e Gabenn <- is wrong, Moneyy <- is wrong, beucase the last 2 letters are repeating
First letter is capital`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}