import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\p{Lu})(?!.*(.)\\1$)\\p{Cyrillic}{3,}$";
final String string = "вася\n"
+ "ва\n"
+ "Ва\n"
+ "Вася\n"
+ "Васяя\n\n"
+ "It's Cyrillic\n"
+ "It's minimum 3 letters\n"
+ "It doesnt have space\n"
+ "The last letters doesnt repeat, i.e Gabenn <- is wrong, Moneyy <- is wrong, beucase the last 2 letters are repeating\n"
+ "First letter is capital";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}