$re = '/^(?=\p{Lu})(?!.*(.)\1$)\p{Cyrillic}{3,}$/m';
$str = 'вася
ва
Ва
Вася
Васяя
It\'s Cyrillic
It\'s minimum 3 letters
It doesnt have space
The last letters doesnt repeat, i.e Gabenn <- is wrong, Moneyy <- is wrong, beucase the last 2 letters are repeating
First letter is capital';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);