using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[4|3|5]([0-9[:space:]\t]{29,31})|[4|3|5]([0-9\s\S\w+]{28})";
string input = @"312345678901234
3123456789012344
\s*(?:\S\s*)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}