package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[4|3|5]([0-9[:space:]\t]{29,31})|[4|3|5]([0-9\s\S\w+]{28})`)
var str = `312345678901234
3123456789012344
\s*(?:\S\s*)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}