const regex = new RegExp('[4|3|5]([0-9[:space:]\\t]{29,31})|[4|3|5]([0-9\\s\\S\\w+]{28})', '')
const str = `312345678901234
3123456789012344
\\s*(?:\\S\\s*)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}