// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[4|3|5]([0-9[:space:]\t]{29,31})|[4|3|5]([0-9\s\S\w+]{28})").unwrap();
let string = "312345678901234
3123456789012344
\\s*(?:\\S\\s*)";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}